IPv6 Subnet Calculator & Address Expander
Calculate IPv6 network prefixes, expand or compress 128-bit addresses, and determine subnet host capacity.
Calculated IPv6 Architecture
Global Unicast (2000::/3)
Full Expanded Notation (RFC 4291)
2001:0db8:85a3:0000:0000:8a2e:0370:7334
RFC 5952 Canonical Compressed Form
2001:db8:85a3::8a2e:370:7334
Network Prefix
2001:db8:85a3:: /64
Total Subnet Capacity
18,446,744,073,709,551,616 (2⁶⁴)
Standard Subnets Contained (/64s)
1 Subnet
IPv6 Address Scope
Public Global Internet
🌐 Architecture Standard: In IPv6, stateless address autoconfiguration (SLAAC) strictly mandates /64 subnets. Never subnet LANs smaller than /64 to ensure host compatibility.
Advertisement
Understanding IPv6 Subnetting & Address Architecture
Internet Protocol version 6 (RFC 8200) replaces the 32-bit address space of IPv4 with a massive 128-bit address space, providing 3.4 × 1038 unique addresses and eliminating the need for NAT.
Common IPv6 Prefix Allocation Standards
| Prefix Length | Addresses | Standard Allocation Purpose |
|---|---|---|
/32 |
296 addresses | Internet Service Providers (ISPs) and Telcos |
/48 |
280 addresses (65,536 × /64 subnets) | Enterprise business networks and data centers |
/56 |
272 addresses (256 × /64 subnets) | Residential broadband and small branch offices |
/64 |
264 addresses (18.4 quintillion) | Standard single broadcast domain / LAN subnet |
/128 |
1 address | Single host loopback or router interface address |
Advertisement
Advertisement